赋予代码灵魂 , 追求极致性能

Hey guys, Here is Vtrois's Blog !

在React Native开发时,添加第三方工程时,遇到以下错误时,该如何解决呢?


The SDK Build Tools revision (23.0.1) is too low for project ‘:react-native-picker’. Minimum required is 25.0.0 ##

解决方案一:
在根目录下的gradle文件中加入以下代码,这样就把每个自工程的buildToolsVersion的版本改为要求的版本了


subprojects { afterEvaluate {project -> if (project.hasProperty("android")) { android { compileSdkVersion 25 buildToolsVersion '25.0.0' } } } }

解决方案二:
在你的build.gradle文件中,如果使用的gradle版本过高,就会出现这种错误,那么相应的解决方案就是把gradle版本降下来

之前代码:

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.3.0'
    }
}


之后代码:

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.2.3'
    }
}
点赞

发表评论

电子邮件地址不会被公开。